Re: disktotalspace()

From: Date: Tue, 15 May 2001 22:40:49 +0000
Subject: Re: disktotalspace()
References: 1 2 3 4 5  Groups: php.dev 
Request: Send a blank email to php-dev+get-55395@lists.php.net to get a copy of this message
On Wed, May 16, 2001 at 01:37:51AM +0300, Zeev Suraski wrote: > >Yes, but this new version will work correctly under Unix-like > >systems and Windows NT / 2000 systems. Executing system binaries > >is sloppy for things like this, anyway. > > > >Or perhaps I'm missing your point? > > I think you were missing the point :) I meant that I think there's no > need to load kernel32.dll and all that, we can simply call > GetDiskFreeSpaceEx() directly. Okay, my lexer wasn't in the correct context when I read your reply. I follow you now. I assume you're suggesting an update of both the existing diskfreespace() and the proposed disktotalspace() functions, correct? > BTW, in light of the standard naming convention initiative, > disktotalspace() is probably a bad name and should be more like > disk_total_space()... How do you feel about renaming the existing diskfreespace() function to disk_free_space() (with an alias for backwards compatibility)? -- Jon Parise (jon@csh.rit.edu) . Rochester Inst. of Technology http://www.csh.rit.edu/~jon/ : Computer Science House Member

« previous php.dev (#55395) next »