Re: disktotalspace()
| From: | Sterling Hughes | Date: | Tue, 15 May 2001 11:14:27 +0000 |
| Subject: | Re: disktotalspace() | ||
| References: | 1 2 3 4 5 6 7 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-55399@lists.php.net to get a copy of this message | ||
Zeev Suraski wrote:
At 01:40 16/5/2001, Jon Parise wrote:-SterlingHow do you feel about renaming the existing diskfreespace() function to disk_free_space() (with an alias for backwards compatibility)?A warm fuzzy feeling :) Seriously though, it's been discussed in great length, and at least from what I understood, going in that direction was the general idea. Slowly, but surely :) Actually, at least what I remember from the conversations, this was being put off till someone actually did some work at renaming a set of the functions, and there are still a good number of unresolved issues regarding function naming (str_tok() or strtok() to name one). At this point, I think placing it in there as disktotalspace() and leaving diskfreespace() alone would be the right thing to do. Then when all the naming issues are hashed out/someone has some work to show, change both of the functions to their proper names. At this point a disk_free_space() function seems out of place in the current naming scheme (I wouldn't object as much to disk_freespace() and disk_totalspace(), but overall, I think we should wait until the rest of the source is namespace complaint and we've decided how to handle the change to the new naming conventions.)