Re: disktotalspace()

From: Date: Wed, 16 May 2001 01:05:38 +0000
Subject: Re: disktotalspace()
References: 1 2  Groups: php.dev 
Request: Send a blank email to php-dev+get-55404@lists.php.net to get a copy of this message
On Tue, May 15, 2001 at 08:50:48AM -0400, Sterling Hughes wrote: > Well, for one thing, no one has agreed on a naming convention yet. > > So its possible that now we'll have two aliases: > > diskfreespace > disk_free_space > > and then the actual function name: > > disk_freespace() > or > disk_space_free() > > Furthermore, it was never agreed that the core functions should follow > any naming conventions. In fact, I think that would be plain stupid. > The extensions should follow a naming convention, however, the core > functions need not follow any such convention. This is how it is with > almost every other language (Perl and C for example). Okay. Well, I'm now wiping my hands of the issue. I'll leave it up to the rest of you folks to establish the naming conventions and make the associated changes in the source and documentation. Would you like me to change the two functions to the "existing" naming scheme (no hyphens) until something new is decided? My changes have only affected the HEAD branch so far, so we don't need to worry about aliasing anything until that code makes it into a release. -- Jon Parise (jon@csh.rit.edu) . Rochester Inst. of Technology http://www.csh.rit.edu/~jon/ : Computer Science House Member

« previous php.dev (#55404) next »