RE: [PHP-DEV] disktotalspace()
| From: | James Moore | Date: | Wed, 16 May 2001 00:01:46 +0000 |
| Subject: | RE: [PHP-DEV] disktotalspace() | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-55401@lists.php.net to get a copy of this message | ||
> > >> How do you feel about renaming the existing diskfreespace()
> > >> function to disk_free_space() (with an alias for backwards
> > >> compatibility)?
> > >
> > > A warm fuzzy feeling :) Seriously though, it's been discussed in
> > > great length, and at least from what I understood, going in that
> > > direction was the general idea. Slowly, but surely :)
> > >
> > Actually, at least what I remember from the conversations, this was
> > being put off till someone actually did some work at renaming a set of
> > the functions, and there are still a good number of unresolved issues
> > regarding function naming (str_tok() or strtok() to name one). At this
> > point, I think placing it in there as disktotalspace() and leaving
> > diskfreespace() alone would be the right thing to do. Then
> when all the
> > naming issues are hashed out/someone has some work to show, change both
> > of the functions to their proper names. At this point a
> > disk_free_space() function seems out of place in the current naming
> > scheme (I wouldn't object as much to disk_freespace() and
> > disk_totalspace(), but overall, I think we should wait until
> the rest of
> > the source is namespace complaint and we've decided how to handle the
> > change to the new naming conventions.)
>
> Ugh. I wish I had read this a few minutes earlier. I just made
> the name change based on what I assumed was consensus.
>
> If someone feels the need to revert the change, go ahead. I
> prefer to just leave it now that I've already changed it, and
> then I'll add the new function as disk_total_space().
Why add more functions to be depreciated soon?? Lets name new functions
properly, bring others into line as and when and as needed add alaises until
we fix it.
- James