Re: zend module patch
| From: | Jason Greene | Date: | Thu, 11 Oct 2001 16:57:55 +0000 |
| Subject: | Re: zend module patch | ||
| References: | 1 2 3 4 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-67785@lists.php.net to get a copy of this message | ||
I highly agree with point 4. At minimum, If it is decided to put this change into 4.0.7,
the release process should reset(rebranch).
I think Stig's suggestion is a good comprimise, so +1
BTW, If we do change to 4.1.0 does that mean I can get some
work in before the branch ? : )
-Jason
----- Original Message -----
From: "Stig S. Bakken" <ssb@alltheweb.com>
To: "Zeev Suraski" <zeev@zend.com>
Cc: "Sascha Schumann" <sascha@schumann.cx>; <php-dev@lists.php.net>
Sent: Wednesday, October 10, 2001 7:05 PM
Subject: Re: [PHP-DEV] zend module patch
> Zeev Suraski wrote:
> >
> > At 23:47 10-10-01, Stig S. Bakken wrote:
> > > > We already broke the API numerous times in 4.0.7. The thing we didn't
> > > > break is the narrow binary compatibility of the module_entry structure.
> > >
> > >If this isn't a reason for 4.1 I don't know one.
> >
> > Stig, really, don't do this to me. I'm seriously considering quitting PHP
> > completely now :)
> >
> > I'll give you another reason which I guess you forgot - and that's the
> > register_globals issue. 4.0.7 and 4.1.0 are supposed to be released
> > simultaneously (or almost simultaneously), with the only real difference
> > being the register_globals default. As you can look up in the archives, I
> > believe it's a pretty crucial step in the deprecation of register_globals
> > in a user-friendly way.
>
> Okay, here's a plan (Zeev and I discussed this on IRC):
>
> 1. Change the 4.0.7 release to 4.1.0 and include the module patch.
> Reasoning: better to have one than two releases breaking compatibility.
> The intention of this patch is to end or at least reduce such
> compatibility problems. And an API change as big as this mandates the
> use of that middle digit we're all so afraid of using. :-)
>
> Sascha: apart from being an unspeakable kludge, won't having two module
> structs just prolong the pain of this change? Wouldn't it be sufficient
> to put a visible warning about it in the release notes and attach a
> README file on converting modules? I think people will accept that when
> it means an end to BC problems if more such changes occur in the future.
>
> 2. Postpone the register_globals default change to 4.2.0
>
> 3. Schedule 4.2.0 as the next release after 4.1.0 (don't even go through
> 4.1.1 unless absolutely necessary)
>
> 4. Either stick to the RC scheme (bug fixes only), or rename them to
> betas.
>
> - Stig
>
> --
> PHP Development Mailing List <http://www.php.net/>
> To unsubscribe, e-mail: php-dev-unsubscribe@lists.php.net
> For additional commands, e-mail: php-dev-help@lists.php.net
> To contact the list administrators, e-mail: php-list-admin@lists.php.net
>
>