Re: Re: Enums, flags and ::
| From: | Christian Weiske | Date: | Tue, 25 Oct 2005 19:33:13 +0000 |
| Subject: | Re: Re: Enums, flags and :: | ||
| References: | 1 2 3 | Groups: | php.gtk.dev |
| Request: | Send a blank email to php-gtk-dev+get-1947@lists.php.net to get a copy of this message | ||
Steph,
> Christian: now that's established, I'm going to put in a plea for upper
> cased constants for gtk.php.net's CS (that's upper cased *including the
> classname*), on grounds of readability if nothing else.
>
> Maybe it's due to our respective mother tongues, but I also have problems
> with Gtk::main() as opposed to gtk::main() - I start looking around for an
> object when I see 'Gtk'.
So we have
> GTK::STATE_ACTIVE
and
> gtk::main()
instead of
> Gtk::STATE_ACTIVE
> Gtk::main()
?
I'd prefer the latter, but if you insist on the first and the others
don't mind..
--
Regards/MfG,
Christian Weiske