Re: Re: Enums, flags and ::
| From: | Andrei Zmievski | Date: | Wed, 26 Oct 2005 03:28:23 +0000 |
| Subject: | Re: Re: Enums, flags and :: | ||
| References: | 1 2 3 | Groups: | php.gtk.dev php.gtk.general |
| Request: | Send a blank email to php-gtk-dev+get-1958@lists.php.net to get a copy of this message | ||
On Oct 25, 2005, at 11:21 AM, Steph Fox wrote:
OK, in that case we're going to need to be loud and clear in the docs. Christian: now that's established, I'm going to put in a plea for upper cased constants for gtk.php.net's CS (that's upper cased *including the classname*), on grounds of readability if nothing else. Maybe it's due to our respective mother tongues, but I also have problems with Gtk::main() as opposed to gtk::main() - I start looking around for an object when I see 'Gtk'.Well, it is a class after all. What's wrong with Gtk as a class name? I'd rather we choose one case standard for class names and stick to it. Let's not be inconsistent. - Andrei