[RFC] Reclassifying engine warnings
| From: | Nikita Popov | Date: | Wed, 28 Aug 2019 09:33:25 +0000 |
| Subject: | [RFC] Reclassifying engine warnings | ||
| Groups: | php.internals | ||
| Request: | Send a blank email to internals+get-106713@lists.php.net to get a copy of this message | ||
Hi internals,
I think it's time to take a look at our existing warnings & notices in the
engine, and think about whether their current classification is still
appropriate. Error conditions like "undefined variable" only generating a
notice is really quite mind-boggling.
I've prepared an RFC with some suggested classifications, though there's
room for bikeshedding here...
https://wiki.php.net/rfc/engine_warnings
Regards,
Nikita