Re: [RFC] Reclassifying engine warnings
| From: | Nikita Popov | Date: | Tue, 10 Sep 2019 13:31:31 +0000 |
| Subject: | Re: [RFC] Reclassifying engine warnings | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-106928@lists.php.net to get a copy of this message | ||
On Wed, Aug 28, 2019 at 11:33 AM Nikita Popov <nikita.ppv@gmail.com> wrote:
> Hi internals,
>
> I think it's time to take a look at our existing warnings & notices in the
> engine, and think about whether their current classification is still
> appropriate. Error conditions like "undefined variable" only generating a
> notice is really quite mind-boggling.
>
> I've prepared an RFC with some suggested classifications, though there's
> room for bikeshedding here...
>
> https://wiki.php.net/rfc/engine_warnings
>
> Regards,
> Nikita
>
Heads up: This RFC may go to vote tomorrow.
Nikita