Re: Re: [RFC] Reclassifying engine warnings

From: Date: Tue, 10 Sep 2019 22:04:43 +0000
Subject: Re: Re: [RFC] Reclassifying engine warnings
References: 1 2  Groups: php.internals 
Request: Send a blank email to internals+get-106929@lists.php.net to get a copy of this message
Den 2019-09-10 kl. 15:31, skrev Nikita Popov:
On Wed, Aug 28, 2019 at 11:33 AM Nikita Popov <nikita.ppv@gmail.com> wrote:
Hi internals, I think it's time to take a look at our existing warnings & notices in the engine, and think about whether their current classification is still appropriate. Error conditions like "undefined variable" only generating a notice is really quite mind-boggling. I've prepared an RFC with some suggested classifications, though there's room for bikeshedding here... https://wiki.php.net/rfc/engine_warnings Regards, Nikita
Heads up: This RFC may go to vote tomorrow. Nikita
Hi, I recall an issue brought up about treatment of logfiles in production environment where PHP warning messages show up. Now, this RFC reclassifies some notices to warnings and some warnings to errors. Now suppose one have as a strategy to correct warnings & errors in logfiles, given that this RFC will lead to new items showing up in logfiles. Is it then worth mentioning in the RFC how this will affect handling to correct warnings & errors in logfiles? E.g. face the changes and fix  it or write some clever error handler to manage it or just try to suppress the new items. Anyway, I'm in favour of this RFC since it gives a more consistent classification of notices, warnings & errors. r//Björn L

« previous php.internals (#106929) next »