Re: stream_register_filter
| From: | Moriyoshi Koizumi | Date: | Mon, 19 May 2003 14:42:36 +0000 |
| Subject: | Re: stream_register_filter | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-1697@lists.php.net to get a copy of this message | ||
Derick Rethans <derick@php.net> wrote:
> On Mon, 19 May 2003, Derick Rethans wrote:
>
> > as we can still correct 'mistakes' I think we should rename
> > stream_register_filter to stream_filter_register in order to have it fit
> > more in line with stream_filter_append and stream_filter_prepend.
> > Comments?
>
> I would suggest doing the same for stream_register_wrapper btw..
I prefer to rename stream_filter_append() / stream_filter_prepend() to
stream_append_filter() / stream_prepend_filter() respectively, and
hopefully I like to get stream_register_filter() renamed to
stream_filter_register() because the former case is about the functions
which operate a specified filter and the latter is the one for operation
to the stream filter registry. Anyway, I'm not very interested in this
trivial issue :)
Moriyoshi