Re: stream_register_filter

From: Date: Mon, 19 May 2003 14:52:37 +0000
Subject: Re: stream_register_filter
References: 1 2  Groups: php.internals 
Request: Send a blank email to internals+get-1704@lists.php.net to get a copy of this message
On Mon, 19 May 2003, Moriyoshi Koizumi wrote: > Derick Rethans <derick@php.net> wrote: > > > On Mon, 19 May 2003, Derick Rethans wrote: > > > > > as we can still correct 'mistakes' I think we should rename > > > stream_register_filter to stream_filter_register in order to have it fit > > > more in line with stream_filter_append and stream_filter_prepend. > > > Comments? > > > > I would suggest doing the same for stream_register_wrapper btw.. > > I prefer to rename stream_filter_append() / stream_filter_prepend() to > stream_append_filter() / stream_prepend_filter() respectively, and > hopefully I like to get stream_register_filter() renamed to That messes up sorting, and logical grouping of function names <extension> <subgroup> <function>... I'm going to change it unless somebody has real objections. Derick -- "my other box is your windows PC" ------------------------------------------------------------------------- Derick Rethans http://derickrethans.nl/ International PHP Magazine http://php-mag.net/ -------------------------------------------------------------------------

« previous php.internals (#1704) next »