Re: Renaming namespaces to packages

From: Date: Fri, 17 Aug 2007 13:24:23 +0000
Subject: Re: Renaming namespaces to packages
References: 1  Groups: php.internals 
Request: Send a blank email to internals+get-31680@lists.php.net to get a copy of this message
Hi, I've updated the patch to be compatible with Dmitry's latest changes: http://schlueters.de/~johannes/php/zend_namespace_to_package_20070817.diff johannes On Fri, 2007-08-10 at 11:26 +0200, Johannes Schlüter wrote: > Hi, > > I think we reached the consensus to rename namespaces to packages as our > implementation is more package-like. Therefore I wrote the corresponding > patch which tries to get rid of all "namespaces" and "ns" (well, not all > "ns" only the namespace-related ones of course) used in the code. > Additionally I changed all package-tests. Any objections? > > Does anybody (with the move-on-CVS-server powers) care about the history > of the tests? Then please cp ZendEngine2/tests/ns_* to pkg_* there else > I'll do a simple cvs rm and cvs add. > > The patch is at > > http://schlueters.de/~johannes/php/zend_namespace_to_package.diff > and > the tarball with the changed tests at > http://schlueters.de/~johannes/php/zend_package_tests.tar.bz2 > > johannes >

« previous php.internals (#31680) next »