Re: Renaming namespaces to packages

From: Date: Fri, 17 Aug 2007 15:29:26 +0000
Subject: Re: Renaming namespaces to packages
References: 1 2 3 4 5  Groups: php.internals 
Request: Send a blank email to internals+get-31686@lists.php.net to get a copy of this message
David, Most people don't know wtf you are referring to by "package", but nearly everyone knows the concept of namespaces. Packages is name for an implementation of namespaces, calling it packages just because language XYZ that I like, does not sound like the best of ideas. On 17-Aug-07, at 11:18 AM, David Coallier wrote:
On 8/17/07, Ilia Alshanetsky <ilia@prohost.org> wrote:
While PHP implementation of namespaces is may not be 100% of what people consider to be namespaces it is close enough and I think the name "namespaces" is most appropriate and clear cut. We don't call PHP objects "Zend Objects" or some other strange name, I don't see why namespaces should be any different IMHO.
If we start calling things what they are, then we might as well do it for the *namespaces* as well ? So ccall them package. And Stanislav, it's not only because java does it that way, it's because python also does, and also because c++ doesn't. After all, why discussing the color of the bikeshed when it's already painted and it's a dogshed ?
On 17-Aug-07, at 11:06 AM, Richard Quadling wrote:
Oh dear. I thought the general feeling was to stick with namespaces? On 17/08/07, Johannes Schlüter <johannes@php.net> wrote:
Hi, I've updated the patch to be compatible with Dmitry's latest changes: http://schlueters.de/~johannes/php/ zend_namespace_to_package_20070817.diff johannes On Fri, 2007-08-10 at 11:26 +0200, Johannes Schlüter wrote:
Hi, I think we reached the consensus to rename namespaces to packages as our implementation is more package-like. Therefore I wrote the corresponding patch which tries to get rid of all "namespaces" and "ns" (well, not all "ns" only the namespace-related ones of course) used in the code. Additionally I changed all package-tests. Any objections? Does anybody (with the move-on-CVS-server powers) care about the history of the tests? Then please cp ZendEngine2/tests/ns_* to pkg_* there else I'll do a simple cvs rm and cvs add. The patch is at http://schlueters.de/~johannes/php/zend_namespace_to_package.diff and the tarball with the changed tests at http://schlueters.de/~johannes/php/zend_package_tests.tar.bz2 johannes
-- PHP Internals - PHP Runtime Development Mailing List To unsubscribe, visit: http://www.php.net/unsub.php
-- ----- Richard Quadling Zend Certified Engineer : http://zend.com/zce.php? c=ZEND002498&r=213474731 "Standing on the shoulders of some very clever giants!"
Ilia Alshanetsky -- PHP Internals - PHP Runtime Development Mailing List To unsubscribe, visit: http://www.php.net/unsub.php
--David Coallier, Founder & Software Architect, Agora Production (http://agoraproduction.com) 51.42.06.70.18
Ilia Alshanetsky

« previous php.internals (#31686) next »