Re: Renaming namespaces to packages

From: Date: Fri, 17 Aug 2007 14:30:29 +0000
Subject: Re: Renaming namespaces to packages
References: 1 2  Groups: php.internals 
Request: Send a blank email to internals+get-31681@lists.php.net to get a copy of this message
Great stuff man! :) Thanks On 8/17/07, Johannes Schlüter <johannes@php.net> wrote: > Hi, > > I've updated the patch to be compatible with Dmitry's latest changes: > > http://schlueters.de/~johannes/php/zend_namespace_to_package_20070817.diff > > johannes > > On Fri, 2007-08-10 at 11:26 +0200, Johannes Schlüter wrote: > > Hi, > > > > I think we reached the consensus to rename namespaces to packages as our > > implementation is more package-like. Therefore I wrote the corresponding > > patch which tries to get rid of all "namespaces" and "ns" (well, not > > all > > "ns" only the namespace-related ones of course) used in the code. > > Additionally I changed all package-tests. Any objections? > > > > Does anybody (with the move-on-CVS-server powers) care about the history > > of the tests? Then please cp ZendEngine2/tests/ns_* to pkg_* there else > > I'll do a simple cvs rm and cvs add. > > > > The patch is at > > âo|åÏÀîû > > �t} Vühttp://schlueters.de/~johannes/php/zend_namespace_to_package.diff and > > the tarball with the changed tests at > > > > http://schlueters.de/~johannes/php/zend_package_tests.tar.bz2 > > > > johannes > > > > -- > PHP Internals - PHP Runtime Development Mailing List > To unsubscribe, visit: http://www.php.net/unsub.php > > -- David Coallier, Founder & Software Architect, Agora Production (http://agoraproduction.com) 51.42.06.70.18

« previous php.internals (#31681) next »