Re: Re: [php-icu] Graphemes and unicode vs intl extension

From: Date: Fri, 21 Mar 2008 17:09:32 +0000
Subject: Re: Re: [php-icu] Graphemes and unicode vs intl extension
References: 1 2 3 4 5 6 7 8  Groups: php.internals 
Request: Send a blank email to internals+get-36241@lists.php.net to get a copy of this message
On Fri, Mar 21, 2008 at 6:01 PM, Tex Texin <tex@yahoo-inc.com> wrote: > I admit to being unclear on why DateFormatter conflicts with Date. I'll have to read the > manuals later. Seems rather limiting if all names beginning with "Date" are now verboten. > That said: > > A) Derick, Shifu, Can you (or anyone) demonstrate the name conflict? I think it should have > been caught by testing if it exists. I'd like to reproduce the problem. > > B) Name change proposals: > > 1) DatetimeFormatter > 2) IntlDateFormatter > 3) TheOtherDateFormatter ;-) > 4) ICUDateFormatter Classess and functions should be prefixed with the extension name according to our naming convention. All functions in pecl/intl should therefore be named intl_foobar() and classes intlFooBar in theory. See ext/date, ext/spl, ext/zip and others for more concrete examples, preferably after reading http://no.php.net/reST/php-src/CODING_STANDARDS -Hannes

« previous php.internals (#36241) next »