Re: [VOTE] 64 bit platform improvements for string length and integer

From: Date: Thu, 30 Jan 2014 21:52:22 +0000
Subject: Re: [VOTE] 64 bit platform improvements for string length and integer
References: 1 2  Groups: php.internals 
Request: Send a blank email to internals+get-71806@lists.php.net to get a copy of this message
Hi Marc, thanks for the comments. On Thu, January 30, 2014 20:53, Marc Bennewitz wrote: > Hi Anatol, > > > As of renaming LONG to INT there is one small inconsistence in the RFC: > - ZEND_STRTOL/ZEND_STRTOUL should be ZEND_STRTOI/ZEND_STRTOUI Sounds logic, as despite ZEND_STRTOL maps strtol(), zend_int_t for instance also not necessarily 'int' literally. Just that the RFC is already being voted ... > - SIZEOF_ZEND_INT should be ZEND_INT_SIZEOF to be consistent with > ZEND_INT_MAX/ZEND_INT_MIN/ZEND_UINT_MAX > This descends from things like SIZEOF_LONG and so on, so completely legit for a C source. > And in my opinion if we go to rename LONG to INT with BC we should also > rename DOUBLE to FLOAT :) > Well, total renames was not the primary goal of this RFC. The renames suggested are to reflect what's going on in the patch and to break compilation with incompatible sources. Such topic asks for a new RFc :) Regards Anatol

« previous php.internals (#71806) next »