Re: [RFC] Fast Parameter Parsing API
| From: | Johannes Schlüter | Date: | Fri, 23 May 2014 13:28:18 +0000 |
| Subject: | Re: [RFC] Fast Parameter Parsing API | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-74452@lists.php.net to get a copy of this message | ||
On Fri, 2014-05-23 at 13:52 +0100, Andrea Faulds wrote:
> On 23 May 2014, at 12:36, Dmitry Stogov <dmitry@zend.com> wrote:
>
> > Please take a look at https://wiki.php.net/rfc/fast_zpp
> >
> > Thanks. Dmitry.
>
> This looks like a great idea. I like how it’s not only faster, but it
> seems to be more readable.
More readable? - I feel exactly the opposite. Yes, we get rid of void
pointers but use a pattern easy to understand. This looks like macro
hell.
If we break APIs anyways: Can't we go for C++ which allows providing
high level APIs with high performance ...
johannes