Re: [RFC] Fast Parameter Parsing API
| From: | Derick Rethans | Date: | Wed, 28 May 2014 11:49:53 +0000 |
| Subject: | Re: [RFC] Fast Parameter Parsing API | ||
| References: | 1 2 3 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-74559@lists.php.net to get a copy of this message | ||
On Fri, 23 May 2014, Johannes Schlüter wrote:
> On Fri, 2014-05-23 at 13:52 +0100, Andrea Faulds wrote:
> > On 23 May 2014, at 12:36, Dmitry Stogov <dmitry@zend.com> wrote:
> >
> > > Please take a look at https://wiki.php.net/rfc/fast_zpp4ýé©/
> > > q²ç•Ü�Äè
> > >
> > > Thanks. Dmitry.
> >
> > This looks like a great idea. I like how it’s not only faster, but
> > it seems to be more readable.
>
> More readable? - I feel exactly the opposite. Yes, we get rid of void
> pointers but use a pattern easy to understand. This looks like macro
> hell.
I don't find it more readable either. From a single line, it goes to 7,
and what if there are three different zpp calls (like in
https://github.com/php/php-src/blob/master/ext/date/php_date.c#L4393)
?
I know the old API is not going away, but I'm not just sure about this
one...
> If we break APIs anyways: Can't we go for C++ which allows providing
> high level APIs with high performance ...
no :-)
cheers,
Derick
--
http://derickrethans.nl | http://xdebug.org
Like Xdebug? Consider a donation: http://xdebug.org/donate.php
twitter: @derickr and @xdebug
Posted with an email client that doesn't mangle email: alpine