Re: [RFC] Fast Parameter Parsing API

From: Date: Fri, 23 May 2014 16:26:37 +0000
Subject: Re: [RFC] Fast Parameter Parsing API
References: 1 2 3 4 5 6  Groups: php.internals 
Request: Send a blank email to internals+get-74461@lists.php.net to get a copy of this message
return to the land :) PHP is used by millions people who never looked into its code. We are working for them BTW: 1% + 1% = 2%, and we already came to 30% :) may be you may propose something that may increase performance at once? Dmitry. On Fri, May 23, 2014 at 8:15 PM, Pierre Joye <pierre.php@gmail.com> wrote: > > On May 23, 2014 5:58 PM, "Dmitry Stogov" <dmitry@zend.com> wrote: > > > > This patch is connected with Zend only in a way, that I worked on it > during last days (it's even not my idea). > > but once I saw the idea I saw how it may be useful. I really don't > understand you attitude to us. > > We are working hard to make a real big step forward... > > > > 2.5% speedup on real-life is not a good gain? where do you live? :) > > In a world where clean code base and easy maintenance are better than a > couple % performance gain. :) > > > Thanks. Dmitry. > > > > > > > > > > On Fri, May 23, 2014 at 7:28 PM, Pierre Joye <pierre.php@gmail.com> > wrote: > >> > >> Hi Dmitry, Bob, > >> > >> On Fri, May 23, 2014 at 3:28 PM, Johannes Schlüter > >> <johannes@schlueters.de> wrote: > >> > On Fri, 2014-05-23 at 13:52 +0100, Andrea Faulds wrote: > >> >> On 23 May 2014, at 12:36, Dmitry Stogov <dmitry@zend.com> wrote: > >> >> > >> >> > Please take a look at > >> >> > https://wiki.php.net/rfc/fast_zpp > >> >> > > >> >> > Thanks. Dmitry. > >> >> > >> >> This looks like a great idea. I like how it’s not only faster, but it > >> >> seems to be more readable. > >> > > >> > More readable? - I feel exactly the opposite. Yes, we get rid of void > >> > pointers but use a pattern easy to understand. This looks like macro > >> > hell. > >> > >> I feel the same way. I very much the idea of rewamping zpp, it is a > >> long due taks. > >> > >> However the way it is implemented in this RFC is not something I would > >> like to work with for a decade or so. The performance gain is also not > >> sufficient enough to justify it. > >> > >> I think we should think more about other options (no matter how long > >> you spent discussing options before posting this RFC). I am sure we > >> can come with other solutions which may be cleaner and also provide > >> some performance improvements. > >> > >> > If we break APIs anyways: Can't we go for C++ which allows providing > >> > high level APIs with high performance ... > >> > >> Yes, C++ would in this case provides almost all we need for > >> implementing parameter management in a clean and efficient way. Not > >> sure if it is desired tho'. > >> > >> By the way, please do not ask me to come with code and cases to valid > >> my comment here, I won't. At least not until things get clarified > >> about we wish. The last thing we need is yet another Zend vs World > >> about that :) > >> > >> Cheers, > >> -- > >> Pierre > >> > >> @pierrejoye | http://www.libgd.org > > > > >

« previous php.internals (#74461) next »