Re: Renaming type-hints to something else?
| From: | Andrea Faulds | Date: | Tue, 16 Sep 2014 15:16:53 +0000 |
| Subject: | Re: Renaming type-hints to something else? | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-77254@lists.php.net to get a copy of this message | ||
Hi!
Here are my thoughts.
The general concept should be called Optional Type Declarations, to replace “Type Hinting".
They are type declarations, and they are optional. Thus the name. For the things themselves,
they’re just Type Declarations, to replace “Type Hints". So, for example:
“I am a big fan of optional type declarations. I am always sure to use a type declaration for my
functions’ parameters and return type. I would very much like to see type declarations for scalar
types added, but realise this is unlikely to happen in the near future.”
For the return type case specifically, it would be a “Return Type Declaration”.
Does that sound reasonable?
Thanks!
--
Andrea Faulds
http://ajf.me/