Re: Renaming type-hints to something else?
| From: | Stas Malyshev | Date: | Wed, 17 Sep 2014 06:05:01 +0000 |
| Subject: | Re: Renaming type-hints to something else? | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-77278@lists.php.net to get a copy of this message | ||
Hi!
> The general concept should be called Optional Type Declarations, to
> replace “Type Hinting". They are type declarations, and they are
> optional. Thus the name. For the things themselves, they’re just Type
> Declarations, to replace “Type Hints". So, for example:
I'd just call it type declarations, the fact that they are optional is
not part of their function, there are many optional things in PHP - e.g.
visibility declaration for class members is optional, but we don't call
it "optional visibility specification", or default values for parameters
are optional, but we don't call them "optional default values". The fact
that they are optional is kind of obvious anyway for anybody who have
seen PHP code since most of PHP function parameters do not have them :)
--
Stanislav Malyshev, Software Architect
SugarCRM: http://www.sugarcrm.com/