Re: Renaming type-hints to something else?
| From: | Levi Morrison | Date: | Tue, 16 Sep 2014 15:24:11 +0000 |
| Subject: | Re: Renaming type-hints to something else? | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-77255@lists.php.net to get a copy of this message | ||
On Tue, Sep 16, 2014 at 9:16 AM, Andrea Faulds <ajf@ajf.me> wrote:
> Hi!
>
> Here are my thoughts.
>
> The general concept should be called Optional Type Declarations, to replace “Type
> Hinting". They are type declarations, and they are optional. Thus the name. For the things
> themselves, they’re just Type Declarations, to replace “Type Hints".
My worry about "optional type declarations" is that once a type is
present it isn't optional anymore. Could be confusing and I am unsure
if that's any better than a "type hint".
If we change it, maybe just call them "type declarations". I think
just referring to them as "types" could be too ambiguous.