Re: Re: Renaming type-hints to something else?
| From: | Andrea Faulds | Date: | Wed, 17 Sep 2014 14:45:10 +0000 |
| Subject: | Re: Re: Renaming type-hints to something else? | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-77290@lists.php.net to get a copy of this message | ||
On 17 Sep 2014, at 15:43, Levi Morrison <levim@php.net> wrote:
> Dropping the suffix:
> ------------------------------
> class ReflectionType
>
> Methods:
> ReflectionFunction::hasReturnType
> ReflectionFunction::getReturnType
> ReflectionParameter::hasType
> ReflectionParameter::getType
This seems to be the cleanest. Perhaps we should just call these “parameter types” and “return
types”, or “type declarations” in full?
--
Andrea Faulds
http://ajf.me/