Re: Re: Renaming type-hints to something else?
| From: | Thomas Gutbier | Date: | Sun, 21 Sep 2014 21:04:52 +0000 |
| Subject: | Re: Re: Renaming type-hints to something else? | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-77417@lists.php.net to get a copy of this message | ||
Am 17.09.2014 um 16:43 schrieb Levi Morrison:
class ReflectionType Methods: ReflectionFunction::hasReturnType ReflectionFunction::getReturnType ReflectionParameter::hasType ReflectionParameter::getTypeThis looks most straightforward to me while I dont see any benefit by adding some suffix like Hint, Decl or Declaration. Also I don't like the term "Type Hinting" already used in the documentation. Despite the change of a well known (but somwhat misleading) term i think it would be more descriptive to call this two concepts "Parameter Types" and "Return Types".