Re: strtolower on get_class in toString

From: Date: Thu, 29 Apr 2004 18:37:23 +0000
Subject: Re: strtolower on get_class in toString
References: 1 2 3 4 5 6 7 8 9 10  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-28571@lists.php.net to get a copy of this message
Hi Lukas: On Thu, Apr 29, 2004 at 08:26:00PM +0200, Lukas Smith wrote: > > to me the purpose of toString is to provide a string to be outputed for > human consumption and not to enable testing. Yes, case sensitive output is nice for readability. At the same time, toString() can be used in scripts, so should be consistent. Enjoy, --Dan -- T H E A N A L Y S I S A N D S O L U T I O N S C O M P A N Y data intensive web and database programming http://www.AnalysisAndSolutions.com/ 4015 7th Ave #4, Brooklyn NY 11232 v: 718-854-0335 f: 718-854-0409

« previous php.pear.dev (#28571) next »