Re: strtolower on get_class in toString

From: Date: Thu, 29 Apr 2004 18:49:09 +0000
Subject: Re: strtolower on get_class in toString
References: 1 2 3 4 5 6 7 8 9 10 11  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-28572@lists.php.net to get a copy of this message
Daniel Convissor wrote:
Hi Lukas: On Thu, Apr 29, 2004 at 08:26:00PM +0200, Lukas Smith wrote:
to me the purpose of toString is to provide a string to be outputed for human consumption and not to enable testing.
Yes, case sensitive output is nice for readability. At the same time, toString() can be used in scripts, so should be consistent.
maybe we can add a parameter .. regards, Lukas Smith smith@backendmedia.com _______________________________ BackendMedia www.backendmedia.com berlin@backendmedia.com Linn Zwoch Smith GbR Pariser Str. 44 D-10707 Berlin Tel +49 30 83 22 50 00 Fax +49 30 83 22 50 07

« previous php.pear.dev (#28572) next »