Re: [PEPr] +1 for Semantic Web::XML_GRDDL

From: Date: Sun, 04 May 2008 05:41:21 +0000
Subject: Re: [PEPr] +1 for Semantic Web::XML_GRDDL
References: 1  Groups: php.pear.dev php.pear.qa 
Request: Send a blank email to pear-dev+get-49998@lists.php.net to get a copy of this message
Michael Gauthier wrote:
Michael Gauthier (http://pear.php.net/user/gauthierm) has voted +1 on the proposal for Semantic Web::XML_GRDDL. Proposal information: http://pear.php.net/pepr/pepr-proposal-show.php?id=533 Vote information: http://pear.php.net/pepr/pepr-vote-show.php?id=533&handle=gauthierm Comment: Looks good. The only complaints I have are coding standards related. The package itself looks interesting and is something I can see myself using at some point but never want to have to write myself ;) I appreciate the documented examples on Google Code. Source comments: 1. missing ?> at the end of files 2. some class members are not documented. Given the large source base and large amount of work it is to document everything I don't think this should prevent a vote but it should be fixed up before a stable release. 3. PEAR's member variable naming conventions are camelCase, not under_scores. 4. methods that return nothing should be documented as @return void, not @return. 5. try running the code through phpcs. It's not bulletproof but it usually turns up small edge-case PEAR coding style issues. Hi everyone,
The third point above mentions that all variables should be camelCase. PHP_CodeSniffer doesn't enforce this rule because, it appears, I never saw anything in the written standard about naming conventions for standard variables. There is a naming conventions page (http://pear.php.net/manual/en/standards.naming.php) but it only talks about class member vars and doesn't define a standard for all variable names. Is this something that should be added to the written standard (and PHP_CodeSniffer) or is it alright to use local variables names like $foo_bar? Or, have I misread or missed a part of the standard? Thanks Greg

« previous php.pear.dev (#49998) next »