Re: HTTP_Client
| From: | Dan Allen | Date: | Sun, 21 Apr 2002 18:27:09 +0000 |
| Subject: | Re: HTTP_Client | ||
| References: | 1 2 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-5711@lists.php.net to get a copy of this message | ||
> I would call it HTTP_UserAgent::detect(). HTTP_UserAgent would
> then be a class containing other user agent related things
Excellent...well, it does already contain some other functions that
deal with the special characteristics of the different browsers, so
I think that will work. Just so happens that the main function is
detect() already. the functions are as follows
detect()
isBrowser()
getBrowser()
getBrowserString()
isOS()
getOS()
getOSString()
setQuirk()
getQuirk()
hasQuirk()
setFeature()
hasFeature()
setFeature()
getUserAgent()
So should I put it in there?
I would anticipate adding
hasLanguage()
getLanguage()
hasEncoding()
getEncoding()
Dan