DB tableInfo ideas

From: Date: Sat, 24 Mar 2001 11:05:39 +0000
Subject: DB tableInfo ideas
Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-79@lists.php.net to get a copy of this message
Hi, Here are some ideas for tableInfo: 1. Overloading the second ($mode) parameter so you can get only a specific type of table info (for example "type") if $mode is a string. 2. Add a parameter that lets you choose a specific column, integer or string. 3. Make the returned "flags" field an assoc. array with the flag name as the key, for example: array("not_null" => bool, "primary_key" => bool, "large_object" => bool) // for ?LOBs There are a few other properties that would be interesting, but that not all databases support in the same way: * character set for text columns * default values * numeric scale/precision Come to think of it, these are really _column_ or _field_ properties, not _table_ properties. Maybe tableInfo should be renamed to fieldInfo or columnInfo? - Stig -- Stig Sæther Bakken <ssb@fast.no> Fast Search & Transfer ASA, Trondheim, Norway

« previous php.pear.dev (#79) next »