Re: Virtual Filesystem

From: Date: Thu, 26 Sep 2002 18:28:25 +0000
Subject: Re: Virtual Filesystem
References: 1  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-9564@lists.php.net to get a copy of this message
On Thu, 26 Sep 2002, Chuck Hagenbuch wrote: > There are two options here. One is to have methods like createFolder() be > smart enough to call different internal functions based on their arguments > (ie, if I get passed an object, do this, otherwise, do that). The other is > to just suck it up and have slightly different function names - > createFolderObject(), etc. Personally I like the first option better. Long method names are quite awkward and having different method names just clutter the API. -- Mika Tuupola http://www.appelsiini.net/~tuupola/

« previous php.pear.dev (#9564) next »