Comment on Doc - function/method names
| From: | Ulf Wendel | Date: | Wed, 01 Mar 2000 12:19:22 +0000 |
| Subject: | Comment on Doc - function/method names | ||
| Groups: | php.pear | ||
| Request: | Send a blank email to php-pear+get-54@lists.php.net to get a copy of this message | ||
Hi everybody,
I was thinking of this note:
"Function and Method Names
Functions (not methods), should be named with underscores, like
this: my_function. Methods should be named with initial
lower-case studlycaps like this: myFunction.",
http://pear.php.net/doc/pear.html
I like the idea that methodnames must not contain underscores. I
do not like the idea that (user-) functions should be named with
underscores. These names should be reserved for php functions.
There's another reason. Do we want packages to contain functions
and/or global variables? I would like to say that a package must
consist of classes.
How about taking the java coding conventions but modify
(simplify) it for the needs of php?
Ulf
--
Ulf Wendel
NetUSE Kommunikationstechnologie GmbH
Siemenswall, D-24107 Kiel, Germany
Fon: +49 431 386435 00 -- Fax: +49 431 386435 99