Re: Comment on Doc - function/method names

From: Date: Wed, 01 Mar 2000 17:55:10 +0000
Subject: Re: Comment on Doc - function/method names
References: 1  Groups: php.pear 
Request: Send a blank email to php-pear+get-60@lists.php.net to get a copy of this message
On Wed, 1 Mar 2000, Stig S. Bakken wrote: > Ulf Wendel wrote: > > > > Hi everybody, > > > > I was thinking of this note: > > > > "Function and Method Names > > > > Functions (not methods), should be named with underscores, like > > this: my_function. Methods should be named with initial > > lower-case studlycaps like this: myFunction.", > > http://pear.php.net/doc/pear.html > > > > I like the idea that methodnames must not contain underscores. I > > do not like the idea that (user-) functions should be named with > > underscores. These names should be reserved for php functions. > > Not much left for user functions then? :-) Maybe we should just drop > the function naming convention completely. > > > There's another reason. Do we want packages to contain functions > > and/or global variables? I would like to say that a package must > > consist of classes. > > We discussed this earlier, and most people seem to want classes only. > However, Andi says static methods are slower, so I'm trying to convince > him to implement namespaces so we can have functions without name > clashes. Stig, we won't want to make a big change like namespaces before PHP 4 is release. Such a big patch could seriously delay it and I remember it not being a trivial change from the talks we had at the PDM. I suggest you go with classes now if that is what you prefer, and we will discuss adding new language features after PHP 4 is released. Andi

« previous php.pear (#60) next »