Re: Comment on Doc - function/method names

From: Date: Wed, 01 Mar 2000 15:22:52 +0000
Subject: Re: Comment on Doc - function/method names
References: 1  Groups: php.pear 
Request: Send a blank email to php-pear+get-56@lists.php.net to get a copy of this message
Ulf Wendel wrote: > > Hi everybody, > > I was thinking of this note: > > "Function and Method Names > > Functions (not methods), should be named with underscores, like > this: my_function. Methods should be named with initial > lower-case studlycaps like this: myFunction.", > http://pear.php.net/doc/pear.html > > I like the idea that methodnames must not contain underscores. I > do not like the idea that (user-) functions should be named with > underscores. These names should be reserved for php functions. Not much left for user functions then? :-) Maybe we should just drop the function naming convention completely. > There's another reason. Do we want packages to contain functions > and/or global variables? I would like to say that a package must > consist of classes. We discussed this earlier, and most people seem to want classes only. However, Andi says static methods are slower, so I'm trying to convince him to implement namespaces so we can have functions without name clashes. > How about taking the java coding conventions but modify > (simplify) it for the needs of php? Is it written out full somewhere? URL? - Stig

« previous php.pear (#56) next »