Re: Prefixing names of new filter functions with filter_
| From: | Derick Rethans | Date: | Thu, 14 Sep 2006 19:00:23 +0000 |
| Subject: | Re: Prefixing names of new filter functions with filter_ | ||
| References: | 1 | Groups: | php.pecl.dev |
| Request: | Send a blank email to pecl-dev+get-4127@lists.php.net to get a copy of this message | ||
On Wed, 13 Sep 2006, Dan Scott wrote:
> So I'm throwing that against the wall to see if anything sticks. If
> there is agreement to the renaming, I'm pretty sure I can whip up a
> patch for the extension / unit tests / docs to get things back in
> sync.
I think we should change some of the names as well, but we need to make
sure that the functions that are used often have short names. Besides
that, we need to change the way how input_get_args uses non-request
data. Instead of using the INPUT_DATA pseudo input type we should create
a filter_data_* type of function that allows you to specify the
information on how to filter data from an array.
regards,
Derick