Re: Prefixing names of new filter functions with filter_

From: Date: Thu, 14 Sep 2006 19:41:07 +0000
Subject: Re: Prefixing names of new filter functions with filter_
References: 1 2  Groups: php.pecl.dev 
Request: Send a blank email to pecl-dev+get-4132@lists.php.net to get a copy of this message
I do not believe it makes sense to made radical API changes in the filter extension this late in the game. The API has been the same for 3 RCs already, I am rather surprised why in the eleventh hour these changes suddenly come out. This is one of the reasons why I didn't think we should've add filter into core this early in the game. Personally and I against any API changes at this time. On 14-Sep-06, at 3:00 PM, Derick Rethans wrote:
On Wed, 13 Sep 2006, Dan Scott wrote:
So I'm throwing that against the wall to see if anything sticks. If there is agreement to the renaming, I'm pretty sure I can whip up a patch for the extension / unit tests / docs to get things back in sync.
I think we should change some of the names as well, but we need to make sure that the functions that are used often have short names. Besides that, we need to change the way how input_get_args uses non-request data. Instead of using the INPUT_DATA pseudo input type we should create a filter_data_* type of function that allows you to specify the information on how to filter data from an array. regards, Derick --PECL development discussion Mailing List (http://pecl.php.net/) To unsubscribe, visit: http://www.php.net/unsub.php
Ilia Alshanetsky

« previous php.pecl.dev (#4132) next »