Lowercase or camelcase function names?

From: Date: Sun, 06 Nov 2011 22:54:32 +0000
Subject: Lowercase or camelcase function names?
Groups: php.pecl.dev 
Request: Send a blank email to pecl-dev+get-8813@lists.php.net to get a copy of this message
Dear developers, I am currently writing an extension for Smart Card communication from within PHP. It uses the PC/SC API and currently I primary take focus on Linux based operating systems using PCSC-Lite[1], but that should not become a problem... The PC/SC API is defined very exactly[2] and uses camelcase definition for function names. For example to connect to a Smart Card the function "SCardConnect" is beeing executed. Is it it a good idea to use the same notation in the function name in a PECL extension? I prefer to call it "scard_connect"... You know how to handle this... ;) What should I do? Thank you very much and regards, Johannes [1] http://pcsclite.alioth.debian.org/pcsclite.html [2] http://www.pcscworkgroup.com/

« previous php.pecl.dev (#8813) next »