Re: Lowercase or camelcase function names?

From: Date: Tue, 15 Nov 2011 05:41:30 +0000
Subject: Re: Lowercase or camelcase function names?
References: 1 2 3 4  Groups: php.pecl.dev 
Request: Send a blank email to pecl-dev+get-8861@lists.php.net to get a copy of this message
On 11/07/2011 04:16 AM, Johannes Schlüter wrote:
you didn't answer my question... CamelCase or not?? ;) But anyway, thank you for your quick reply. :D
Wasn't sure what to answer there ;-) PHP in that area is inconsistent.
Only because some people prefer to ignore the standards. See CODING_STANDARDS in the sources: Naming Conventions ------------------
                                                                                                                                                             1.  Function names for user-level functions should be enclosed with in
    the PHP_FUNCTION() macro. They should be in lowercase, with words
    underscore delimited, with care taken to minimize the letter count.
    Abbreviations should not be used when they greatly decrease the
    readability of the function name itself::
... 6. Method names follow the 'studlyCaps' (also referred to as 'bumpy case'
    or 'camel caps') naming convention, with care taken to minimize the
    letter count. The initial letter of the name is lowercase, and each
    letter that starts a new 'word' is capitalized::
... -- Wbr, Antony Dovgal --- http://pinba.org - realtime profiling for PHP

« previous php.pecl.dev (#8861) next »