Bug #17826 Updated: PHP 4.2.1 Apache SAPI is not compatible with Apache 2.0.39
| From: | davidpatrick at rogers dot com | Date: | Thu, 20 Jun 2002 12:53:49 +0000 |
| Subject: | Bug #17826 Updated: PHP 4.2.1 Apache SAPI is not compatible with Apache 2.0.39 | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-11561@lists.php.net to get a copy of this message | ||
ID: 17826
Updated by: davidpatrick@rogers.com
Reported By: jan@penninkhof.com
Status: Closed
Bug Type: Apache2 related
Operating System: Win32
PHP Version: 4.2.1
Assigned To: edink
New Comment:
as listed by edink@php.net
download this sapi
http://ftp.proventum.net/pub/php/win32/php4.2.x-apache2.zip
it will work with Apache 2.0.39 php 4.2.1 on win32
Previous Comments:
------------------------------------------------------------------------
[2002-06-19 11:56:12] derick@php.net
It's a development version, but that doesn't really matter as Apache
itself is not really stable either.
Derick
------------------------------------------------------------------------
[2002-06-19 11:50:51] dmiyachi@co.sutter.ca.us
Also, is this latest cvs version a fix for 4.2.1 or a development
release?
Displaying phpinfo() shows that the cvs version is 4.3.0-Dev, so are we
now dealing with an unstable version?
Can someone change the status of this bug to Open based on my previous
entry as well as this one?
------------------------------------------------------------------------
[2002-06-19 11:10:30] dmiyachi@co.sutter.ca.us
The lastest cvs version as refered by the [19 Jun 7:06am] edink@php.net
entry is incomplete as it does not contain all the dll's in the
/extensions directory including the php_pgsql.dll that I need to load.
On apache startup the following error msg are found in the Win2K event
viewer:
1) Application popup: Warning : Unable to load dynamic library
'c:\php421\extensions/php_pgsql.dll' - The specified procedure could
not be found.
2) Application popup: Apache.exe - Entry Point Not Found : The
procedure entry point php_fopen_wrapper could not be located in the
dynamic link library php4ts.dll.
I've followed standard installation procedures as I have done with
prior versions (4.2.1 for apache 2.36), but the latest 4.2.1 for apache
2.39 fails to install/run correctly because of the aforementioned
errors.
------------------------------------------------------------------------
[2002-06-19 10:21:47] Joe@system03.freeserve.co.uk
Not only on windows systems, running this on Unix (redhat Linux) also
produces this error:
httpd: module "sapi_apache2.c" is not compatible with this version of
Apache
------------------------------------------------------------------------
[2002-06-19 07:06:30] edink@php.net
This bug has been fixed in CVS. You can grab a snapshot of the
CVS version at http://snaps.php.net/. In case this was a
documentation
problem, the fix will show up soon at http://www.php.net/manual/.
In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites.
Thank you for the report, and for helping us make PHP better.
You could also try
http://ftp.proventum.net/pub/php/win32/php4.2.x-apache2.zip
which might
work with PHP 4.2.1.
The correct link for the cvs version is:
http://snaps.php.net/win32/php4-win32-latest.zip
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/17826
--
Edit this bug report at http://bugs.php.net/?id=17826&edit=1