#17826 [Com]: PHP 4.2.1 Apache SAPI is not compatible with Apache 2.0.39

From: Date: Fri, 23 Aug 2002 16:40:36 +0000
Subject: #17826 [Com]: PHP 4.2.1 Apache SAPI is not compatible with Apache 2.0.39
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-17676@lists.php.net to get a copy of this message
ID: 17826 Comment by: doron@ben-david.co.il Reported By: jan@penninkhof.com Status: Closed Bug Type: Apache2 related Operating System: Win32 PHP Version: 4.2.1 Assigned To: edink New Comment: Indeedlido :)... same here... XP pro, apache 2.0.40, latest php from the CVS. same error: C:\WINDOWS\system32>net start apache2 The Apache2 service is starting. The Apache2 service could not be started. A service specific error occurred: 1. More help is available by typing NET HELPMSG 3547. Previous Comments: ------------------------------------------------------------------------ [2002-08-21 06:26:46] DaRKoNe@MicroShit.NL Ok.. same problem here.. WinXP Pro Apache 2.0.40 PHP 4.2.2 "Cannot load C:/php4/sapi/php4apache2.dll into server: The specified module could not be found." Downloaded new php4apache2.dll.. didn't work.. So what's the next step ? ------------------------------------------------------------------------ [2002-08-21 02:20:06] tongo@bossig.com Okay, exact same problem with Apache 2.0.4 and PHP 4.2.2. New php4apache.dll didn't help. Win2k SP2 for an os. ------------------------------------------------------------------------ [2002-07-14 19:11:18] roach2010@hotmail.com Thankyou very much. I was just about to tear my hair out when i found a link to this page and finally I have managed to get Apache 2.0.39 to use the API thanks to the PHP/4.2.2-dev posted here. This being my first encounter of Apache/PHP, I just assumed that I was doing something completely wrong. Now I have no excuse for not reading the manual :( ------------------------------------------------------------------------ [2002-07-13 10:49:37] baxant@cogeco.ca I use the CVS release and still I get errors. I run the test configuration and get 2 error windows instead of one like in the public release, and then Apache gets shut down by windows. So anyone know when Apache 2.0.40 will be out and fix the PHP Dilemma that all of us are having??? ------------------------------------------------------------------------ [2002-07-11 12:12:06] hubweb@hotmail.com Forget it... that problem was caused by MSIE... what a surprise ! ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/17826 -- Edit this bug report at http://bugs.php.net/?id=17826&edit=1

« previous php.bugs (#17676) next »