#17826 [Com]: PHP 4.2.1 Apache SAPI is not compatible with Apache 2.0.39
| From: | ender at unset dot net | Date: | Sun, 10 Nov 2002 23:51:19 +0000 |
| Subject: | #17826 [Com]: PHP 4.2.1 Apache SAPI is not compatible with Apache 2.0.39 | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-24466@lists.php.net to get a copy of this message | ||
ID: 17826
Comment by: ender@unset.net
Reported By: jan@penninkhof.com
Status: Closed
Bug Type: Apache2 related
Operating System: Win32
PHP Version: 4.2.1
Assigned To: edink
New Comment:
FYI - The files referenced above are back online. Thanks, imajes, for
your quick response!
Previous Comments:
------------------------------------------------------------------------
[2002-11-10 13:28:47] imajes@php.net
snaps has moved server, and win32 snaps haven't been uploaded yet.
please bear with us as we fix this.
Thanks
------------------------------------------------------------------------
[2002-11-10 13:16:51] ender@unset.net
I appreciate all the information posted on this bug, but does anyone
know what's wrong with snaps.php.net? I can't download the file that's
referenced above,
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
Does anyone have any information on what's going on with snaps.php.net?
------------------------------------------------------------------------
[2002-11-10 05:31:47] mclogiciel@btinternet.com
What is the fix for this bug... ? Is there a new bug fix - I have the
same error. What is the workaround and can somone answer the last
entry. This error makes depressing reading. The snspsnap latest zip
page is inaccessible at this moment. Why is this bug "closed" ?
------------------------------------------------------------------------
[2002-11-02 21:28:33] phn737@hotmail.com
I have a question for the comment by:
[23 Oct 8:52pm] blalond@umich.edu
You omit the following line in your httpd.conf:
AddModule mod_php4.c
So how is the mod_php4.c module being loaded?
This is the error if AddModule is used:
C:\Apache2043\bin>apache -t
Syntax error on line 976 of C:/Apache2043/conf/httpd.conf:
Invalid command 'AddModule', perhaps mis-spelled or defined by a module
not included in the server configuration
Thank you
------------------------------------------------------------------------
[2002-10-23 20:52:41] blalond@umich.edu
If you're getting
"Cannot load C:/php4/sapi/php4apache2.dll into server: The specified
module could not be found."
or
"apache: module "c:\php4build\snap\sapi\apache2filter\sapi_apache2.c"
is not compatible with this version of Apache (found 20020628, need
20020903)."
I got it working and this is everything I did:
1. Download:
a. Apache: apache_2.0.43-win32-x86-no_ssl.msi
b. PHP: php-4.2.3-Win32.zip
c. Latest PHP Snap:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
2. Install
a. apache
b. PHP (by upzipping and renaming dir to "c:\php"
2. Copy c:\php\php.ini-recommended to c:\windows\php.ini
3. Edit c:\php.ini
-doc_root = [current apache doc root]
-extension_dir = C:\php\extensions
4. Copy c:\php\php4ts.dll to c:\winnt\system32\
4. Copy php4apache2.dll from the c. Snap zip file to c:\php\sapi\
6. Edit Apache's configuration file and add:
LoadModule php4_module c:/php/sapi/php4apache2.dll
AddType application/x-httpd-php .php
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/17826
--
Edit this bug report at http://bugs.php.net/?id=17826&edit=1