#17826 [Com]: PHP 4.2.1 Apache SAPI is not compatible with Apache 2.0.39

From: Date: Thu, 03 Oct 2002 13:05:03 +0000
Subject: #17826 [Com]: PHP 4.2.1 Apache SAPI is not compatible with Apache 2.0.39
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-21378@lists.php.net to get a copy of this message
ID: 17826 Comment by: jhiltunen@genencor.com Reported By: jan@penninkhof.com Status: Closed Bug Type: Apache2 related Operating System: Win32 PHP Version: 4.2.1 Assigned To: edink New Comment: I have tried to get Apache 2.0.4.2 and PHP latest (tested many versions) working together, but I am not able to. I get similar erros what everybody else here. After two hours googling, yahooing etc. I found apache2filter.dll from old 4.20 package, but that doesn't work either. I am stuck with new Apacje 2.0 version and I don't have a clue how I can get my Apache/MySQL/PHP server functioning (except roll-back from backups). Apache developers should display warning that PHP doesn't work with Apache2 ! Previous Comments: ------------------------------------------------------------------------ [2002-10-02 22:11:54] Tim@vwgeek.com My version is doing same thing, cannot load C/PHP4/sapi/php4apache2.dll into server, specified procedure cannot be found XP Pro SP1 Apache 2.0.42 PHP 4.2.3 I even tried the older version of the dll, no luck, I also tried to load the module directly into the modules directoy, no luck, does php4ts.dll need to be specified, as it always has to run/ Off to try that now. Tim ------------------------------------------------------------------------ [2002-09-04 03:20:01] crazed@zonnet.nl Right.. It is now september... I just dl'ed the latest (i may hope) php4.2.2 zipped distribution. Running XP Pro Apache 2.0.40 And i get this error in the application log: The Apache service named reported the following error: >>> Cannot load G:/php-4/sapi/php4apache2.dll into server: Can't find stated procedure. One would think this had been solved from what i read above... Off to find "newer" releases now.. ------------------------------------------------------------------------ [2002-08-24 21:58:19] roman_alexandru_gabriel@hotmail.com Forget that. Sorry. I downloaded the latest version and it worked!!! You all should do the same. ------------------------------------------------------------------------ [2002-08-24 21:33:11] roman_alexandru_gabriel@otmail.com As the last three or four messages I have problems running Apache 2.0.40 with PHP 4.2.2. I use Windows XP Professional. I tried to start Apache from the command prompt(interpreter) and this is the listing: <--START OF LISTING--> Microsoft Windows XP [Version 5.1.2600] (C) Copyright 1985-2001 Microsoft Corp. C:\Documents and Settings\alex>net start apache2 The Apache2 service is starting. The Apache2 service could not be started. A service specific error occurred: 1. More help is available by typing NET HELPMSG 3547. C:\Documents and Settings\alex>NET HELPMSG 3547 A service specific error occurred: ***. EXPLANATION A service-specific error occurred. ACTION Refer to the Help or documentation for that service to determine the problem. <--END OF LISTING--> I do not know what could have caused this problem. If someone knows what is going on here... please help. Thank you in advance! ------------------------------------------------------------------------ [2002-08-23 15:34:51] leithal@cool-tools.co.uk I'm getting this exact same error as well! Same setup as the last three posts.. Has anyone come across a solution for this yet? ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/17826 -- Edit this bug report at http://bugs.php.net/?id=17826&edit=1

« previous php.bugs (#21378) next »