Bug #75579 [NEW]: All Interned Strings Free memory used and PHP crashes

From: Date: Mon, 27 Nov 2017 10:32:08 +0000
Subject: Bug #75579 [NEW]: All Interned Strings Free memory used and PHP crashes
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-212742@lists.php.net to get a copy of this message
From:             post at minhost dot no
Operating system: CentOS 7.4
PHP version:      7.1.12
Package:          opcache
Bug Type:         Bug
Bug description:All Interned Strings Free memory used and PHP crashes

Description:
------------
We are running PHP-FPM with OPCache. The servers are shared hosting
servers with many WordPress sites. After upgrading from PHP 7.1.11 to
PHP 7.1.12, several PHP sites started to crash, and after a while, they
was all down. When downgrading to PHP 7.1.11, all works correct again.

It seems to be opcache interned_strings_buffer, that is the cause. For
example when still running PHP 7.1.11 it looks like this in a PHP info
page:

Interned Strings Used memory	369608
Interned Strings Free memory	3824696

After upgrading to PHP 7.1.12 it looks like this (and PHP sites stops
working):
Interned Strings Used memory	4194272
Interned Strings Free memory	32

I have not tested this on PHP 7.0.26, but I suspect the problem is the
same on that version.

Conclusion: So, after upgrade toi PHP 7.1.12, ALL available "Interned
Strings Free memory" is used, and PHP sites start going down.
Downgrading to PHP 7.1.11 solves the problem.

In apache error log for the domains, I had lines like this:
Sun Nov 26 12:00:53.161278 2017] [proxy_fcgi:error] [pid 25870:tid
139679914243840] [client 176.74.214.18:8405] AH01067: Failed to read
FastCGI header

[Sun Nov 26 12:00:53.161304 2017] [proxy_fcgi:error] [pid 25870:tid
139679914243840] (104)Connection reset by peer: [client
176.74.214.18:8405] AH01075: Error dispatching request to :

In php-fpm.log I had lines like this:
[26-Nov-2017 11:52:04] NOTICE: [pool USERNAME] child 25329 started

[26-Nov-2017 11:52:04] WARNING: [pool USERNAME] child 24302 exited on
signal 11 (SIGSEGV) after 1.864571 seconds from start


-- 
Edit bug report at https://bugs.php.net/bug.php?id=75579&edit=1
-- 
Try a snapshot (PHP 5.4):   https://bugs.php.net/fix.php?id=75579&r=trysnapshot54
Try a snapshot (PHP 5.5):   https://bugs.php.net/fix.php?id=75579&r=trysnapshot55
Try a snapshot (trunk):     https://bugs.php.net/fix.php?id=75579&r=trysnapshottrunk
Fixed in SVN:               https://bugs.php.net/fix.php?id=75579&r=fixed
Fixed in release:           https://bugs.php.net/fix.php?id=75579&r=alreadyfixed
Need backtrace:             https://bugs.php.net/fix.php?id=75579&r=needtrace
Need Reproduce Script:      https://bugs.php.net/fix.php?id=75579&r=needscript
Try newer version:          https://bugs.php.net/fix.php?id=75579&r=oldversion
Not developer issue:        https://bugs.php.net/fix.php?id=75579&r=support
Expected behavior:          https://bugs.php.net/fix.php?id=75579&r=notwrong
Not enough info:            https://bugs.php.net/fix.php?id=75579&r=notenoughinfo
Submitted twice:            https://bugs.php.net/fix.php?id=75579&r=submittedtwice
register_globals:           https://bugs.php.net/fix.php?id=75579&r=globals
PHP 4 support discontinued: https://bugs.php.net/fix.php?id=75579&r=php4
Daylight Savings:           https://bugs.php.net/fix.php?id=75579&r=dst
IIS Stability:              https://bugs.php.net/fix.php?id=75579&r=isapi
Install GNU Sed:            https://bugs.php.net/fix.php?id=75579&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=75579&r=float
No Zend Extensions:         https://bugs.php.net/fix.php?id=75579&r=nozend
MySQL Configuration Error:  https://bugs.php.net/fix.php?id=75579&r=mysqlcfg



Thread (52 messages)

« previous php.bugs (#212742) next »