Bug #75579 [Opn]: All Interned Strings Free memory used and PHP crashes

From: Date: Tue, 28 Nov 2017 08:28:54 +0000
Subject: Bug #75579 [Opn]: All Interned Strings Free memory used and PHP crashes
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-212763@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=75579&edit=1 ID: 75579 User updated by: post at minhost dot no Reported by: post at minhost dot no Summary: All Interned Strings Free memory used and PHP crashes Status: Open Type: Bug Package: opcache Operating System: CentOS 7.4 PHP Version: 7.1.12 Block user comment: N Private report: N New Comment: If it helps, here is my opcache settings (please note this is servers with 128 GB RAM): opcache.memory_consumption=32768 opcache.interned_strings_buffer=4 opcache.max_accelerated_files=1000000 opcache.revalidate_freq=0 opcache.validate_timestamps=1 opcache.fast_shutdown=1 opcache.enable_cli=0 opcache.validate_permission=1 opcache.validate_root=1 opcache.use_cwd=1 opcache.revalidate_path=1 opcache.enable_file_override=1 opcache.file_cache=/var/www/tmp/.opcache opcache.file_cache_only=0 opcache.max_wasted_percentage=10 Previous Comments: ------------------------------------------------------------------------ [2017-11-27 10:32:02] post at minhost dot no Description: ------------ We are running PHP-FPM with OPCache. The servers are shared hosting servers with many WordPress sites. After upgrading from PHP 7.1.11 to PHP 7.1.12, several PHP sites started to crash, and after a while, they was all down. When downgrading to PHP 7.1.11, all works correct again. It seems to be opcache interned_strings_buffer, that is the cause. For example when still running PHP 7.1.11 it looks like this in a PHP info page: Interned Strings Used memory 369608 Interned Strings Free memory 3824696 After upgrading to PHP 7.1.12 it looks like this (and PHP sites stops working): Interned Strings Used memory 4194272 Interned Strings Free memory 32 I have not tested this on PHP 7.0.26, but I suspect the problem is the same on that version. Conclusion: So, after upgrade toi PHP 7.1.12, ALL available "Interned Strings Free memory" is used, and PHP sites start going down. Downgrading to PHP 7.1.11 solves the problem. In apache error log for the domains, I had lines like this: Sun Nov 26 12:00:53.161278 2017] [proxy_fcgi:error] [pid 25870:tid 139679914243840] [client 176.74.214.18:8405] AH01067: Failed to read FastCGI header [Sun Nov 26 12:00:53.161304 2017] [proxy_fcgi:error] [pid 25870:tid 139679914243840] (104)Connection reset by peer: [client 176.74.214.18:8405] AH01075: Error dispatching request to : In php-fpm.log I had lines like this: [26-Nov-2017 11:52:04] NOTICE: [pool USERNAME] child 25329 started [26-Nov-2017 11:52:04] WARNING: [pool USERNAME] child 24302 exited on signal 11 (SIGSEGV) after 1.864571 seconds from start ------------------------------------------------------------------------ -- Edit this bug report at https://bugs.php.net/bug.php?id=75579&edit=1

« previous php.bugs (#212763) next »