Bug #75579 [Opn]: All Interned Strings Free memory used and PHP crashes
| From: | post at minhost dot no | Date: | Fri, 15 Dec 2017 19:50:20 +0000 |
| Subject: | Bug #75579 [Opn]: All Interned Strings Free memory used and PHP crashes | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-213123@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=75579&edit=1
ID: 75579
User updated by: post at minhost dot no
Reported by: post at minhost dot no
Summary: All Interned Strings Free memory used and PHP
crashes
Status: Open
Type: Bug
Package: opcache
Operating System: CentOS 7.4
PHP Version: 7.1.12
Block user comment: N
Private report: N
New Comment:
I just now today installed the latest 7.1 development branch from here https://github.com/php/php-src/branches and
tested it. I am sorry to see the problem is still not solved with any of the patches that have been
made so far. PHP still crashes for me after visiting a few WordPress sites. This time it seemed to
happen right after opcache got a automatic OOM restart.
Previous Comments:
------------------------------------------------------------------------
[2017-12-05 10:44:01] post at minhost dot no
Related To: Bug #75621
------------------------------------------------------------------------
[2017-12-05 10:12:33] pascal dot nobus at webservice dot be
Related To: Bug #75621
------------------------------------------------------------------------
[2017-12-05 09:05:58] post at minhost dot no
Related To: Bug #75621
------------------------------------------------------------------------
[2017-11-30 15:09:47] post at minhost dot no
Looking closer at apache error log for the domains when PHP sites start to go down I also get errors
like this:
[Thu Nov 30 15:38:32.577627 2017] [proxy_fcgi:error] [pid 17992:tid 140239062427392] [client
176.74.214.18:52690] AH01067: Failed to read FastCGI header
[Thu Nov 30 15:38:32.577665 2017] [proxy_fcgi:error] [pid 17992:tid 140239062427392] (104)Connection
reset by peer: [client 176.74.214.18:52690] AH01075: Error dispatching request to :
------------------------------------------------------------------------
[2017-11-30 14:49:02] post at minhost dot no
I spoke to soon. After more testing on PHP 7.1.12 with the patch from bug #75573 applied: http://git.php.net/?p=php-src.git;a=commit;h=3b9ba7b6bd9e24bdbeca8e8e3f24cee2fccc51d8
- still the bug is present! After visiting about nine wordpress sites on the test server, the
interned strings used memory became full and PHP sites started to crash and go down. From apache
error log for one of the domains after it stopped working:
[Thu Nov 30 15:40:40.273796 2017] [proxy_fcgi:error] [pid 17990:tid 140238684755712] [client
176.74.214.18:42343] AH01071: Got error 'PHP message: PHP Fatal error: Cannot declare
interface JsonSerializable, because the name is already in use in
/home/USER/domains/DOMAIN.TLD/public_html/wp-includes/compat.php on line 428\n'
[Thu Nov 30 15:40:41.697018 2017] [proxy_fcgi:error] [pid 17990:tid 140238693148416] [client
176.74.214.18:52760] AH01071: Got error 'PHP message: PHP Fatal error: Cannot declare
interface JsonSerializable, because the name is already in use in
/home/USER/domains/DOMAIN.TLD/public_html/wp-includes/compat.php on line 428\n'
So this still prevents us from upgrading to PHP 7.1.12. Remeber the bug is not present in PHP 7.1.11
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=75579
--
Edit this bug report at https://bugs.php.net/bug.php?id=75579&edit=1