php install probs
| From: | Todd Martin | Date: | Thu, 30 Nov 2000 09:19:59 +0000 |
| Subject: | php install probs | ||
| References: | 1 | Groups: | php.general |
| Request: | Send a blank email to php-general+get-28005@lists.php.net to get a copy of this message | ||
I get this error message when trying to start apache up for the first time
with php4.
Config is:
apache 1.3.14
php4.0.3pl3
Red Hat 6.0
None of these packages are RPM's, I compiled it all from source, including
the apache mod_so support. I didn't get any errors or warnings during
configure or compile.
Below are the two relevant lines from my httpd.conf files:
LoadModule php4_module libexec/libphp4.so
AddType application/x-httpd-php .php
Now this is the confusing part. The php INSTALL file says I only need that
second line, but if I only use that second line then my test.php script
comes up as source rather than displaying it's intended output.
[root@www conf]# apachectl restart
/usr/local/apache/bin/apachectl restart: httpd not running, trying to start
Syntax error on line 207 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server:
/usr/local/apache/libexec/libphp4.so: undefined symbol: zendtext
/usr/local/apache/bin/apachectl restart: httpd could not be started
[root@www conf]#
Anyway, help would be mucho appreciated. Thanks folks!
-todd