Re: [RFC] Deprecations for PHP 7.3
| From: | Stanislav Malyshev | Date: | Thu, 05 Jul 2018 20:22:18 +0000 |
| Subject: | Re: [RFC] Deprecations for PHP 7.3 | ||
| References: | 1 2 3 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-102615@lists.php.net to get a copy of this message | ||
Hi!
> After looking into this, I think that FILTER_SANITIZE_MAGIC_QUOTES may be a
> legitimate filter, which just has a bad name. Next to other filters that
> perform htmlspecialchars and urlencode, it makes sense that there is also a
> filter that performs addslashes. Maybe we should just rename this filter to
> something which is not tainted by the "magic quotes" terminology?
Makes sense. There's nothing specially evil in addslashes if used in
appropriate context. Also, for those that are newer to PHP, "magic
quotes" means very little. So it's a bad name from various perspectives.
Having something like FILTER_SANITIZE_ADD_SLASHES would be fine.
--
Stas Malyshev
smalyshev@gmail.com