Re: [RFC] Deprecations for PHP 7.3
| From: | Nikita Popov | Date: | Thu, 05 Jul 2018 20:14:54 +0000 |
| Subject: | Re: [RFC] Deprecations for PHP 7.3 | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-102614@lists.php.net to get a copy of this message | ||
On Tue, Jun 26, 2018 at 10:22 PM, Kalle Sommer Nielsen <kalle@php.net>
wrote:
> Den søn. 24. jun. 2018 kl. 18.47 skrev Nikita Popov <nikita.ppv@gmail.com
> >:
> > If you have a minor deprecation in mind, but were too lazy to write an
> RFC
> > for it, please write me a mail until tomorrow, so that it might be
> included
> > as part of this proposal. As time is limited I don't want to include
> > anything larger or controversial in this RFC though.
>
> I took the liberty and added the FILTER_SANITIZE_MAGIC_QUOTES to the
> RFC so we may once and for all get rid of magic_quotes.
>
After looking into this, I think that FILTER_SANITIZE_MAGIC_QUOTES may be a
legitimate filter, which just has a bad name. Next to other filters that
perform htmlspecialchars and urlencode, it makes sense that there is also a
filter that performs addslashes. Maybe we should just rename this filter to
something which is not tainted by the "magic quotes" terminology?
Nikita