Re: PHP OO naming conventions
| From: | Maxim Maletsky | Date: | Thu, 15 May 2003 17:46:36 +0000 |
| Subject: | Re: PHP OO naming conventions | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-1541@lists.php.net to get a copy of this message | ||
On Thu, 15 May 2003 13:59:38 +0200
"Lukas Smith" <smith@backendmedia.com> wrote:
> I would therefore propose to use studlyCaps as the CS for PHP OO APIs.
>
> Current: $foo->execute_query($query, $param);
> New: $foo->executeQuery($query, $param);
I personally don't really like studyCaps as any naming convention in PHP for
two reasons:
1. PHP rarely uses it
2. Could be confusing for user
just my own .02 cents
--
Maxim Maletsky
maxim@php.net