Re: PHP OO naming conventions

From: Date: Thu, 15 May 2003 18:11:02 +0000
Subject: Re: PHP OO naming conventions
References: 1  Groups: php.internals 
Request: Send a blank email to internals+get-1544@lists.php.net to get a copy of this message
At 19:48 15.05.2003, George Schlossnagle wrote:
On Thursday, May 15, 2003, at 01:46 PM, Maxim Maletsky wrote:
On Thu, 15 May 2003 13:59:38 +0200 "Lukas Smith" <smith@backendmedia.com> wrote:
I would therefore propose to use studlyCaps as the CS for PHP OO APIs. Current: $foo->execute_query($query, $param);
New:     $foo->executeQuery($query, $param);
I personally don't really like studyCaps as any naming convention in PHP for two reasons: 1. PHP rarely uses it
PHP itself has almost no objects defined in extensions. PEAR does though, and is widely considered to be 'the standard' for writing OO perl. And it has studlyCaps as one of it's CS standards.
Yes! For PHP4 only domxml made some more use of OO from within an extension. And domxml is an exception itself since it has to follow W3C naming. With PHP 5 this will change so i think it is a very good idea to use the same naming convention PEAR already uses. (Now it is little work) marcus

« previous php.internals (#1544) next »